For some time I've been eagerly anticipating the Android app from, and now that it's in release 1.0.3 I thought I'd give it a go. So earlier this evening I bought and loaded the app, and two hours later I uninstalled it and got the refund from the app store.


I knew that the app was not quite as fancy and feature rich as the iPhone app, but I was astonished how under-whelmingly basic it. It is really really basic and very clunky to work with. looking at a cache is not merely a matter of scrooling down over the information - you need to go into sub screens all the time which gets tedious pretty quick.

I then tried to load a gpx file for offline caching (lets face it, the good caches are often in places without network), the loading went well and I could read all the info. But as soon as I switched off the network it wouldn't load anything and stated that a network connection is needed! I tried to load the offline file and the app promptly crashed. :wacko:

So when it had crashed about 4 times for different (or no) reasons I decided to throw in the towel.